If you would like to integrate your CRM 2015 tenant into your Outlook desktop client, please ensure that your system meets the following software requirements:


Operating System: Windows 7 Service Pack 1, Windows 8, Windows 8.1, Windows 10

Web Browser: Internet Explorer 10, Internet Explorer 11

Microsoft Office: Office 2010, Office 2013


Please note that Office 2016 is not supported at this time.